What’s Vulnerable › Vulnerabilities
CVE-2024-5770: WP Force SSL & HTTPS SSL Redirect <= 1.66 - Missing Authorization to Settings Update
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-08 · updated 2026-06-17
- Weakness: CWE-862
Description
The WP Force SSL & HTTPS SSL Redirect plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'ajax_save_setting' function in versions up to, and including, 1.66. This makes it possible for authenticated attackers, subscriber-level permissions and above, to update the plugin settings.
Affected products
- webfactory WP Force SSL & HTTPS SSL Redirect: before 1.67 — fixed in 1.67
How to fix
Upgrade to a fixed version: webfactory WP Force SSL & HTTPS SSL Redirect 1.67. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-force-ssl/tags/1.66/wp-force-ssl.php#L953
- https://plugins.trac.wordpress.org/changeset/3099110/
- https://swisskyrepo.github.io/PayloadsAllTheThings/CRLF%20Injection/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c2081e4a-c6b7-4730-be59-bc728b90ecaa?source=cve
- https://plugins.trac.wordpress.org/browser/wp-force-ssl/tags/1.66/wp-force-ssl.php#L953
- https://plugins.trac.wordpress.org/changeset/3099110/
- https://swisskyrepo.github.io/PayloadsAllTheThings/CRLF%20Injection/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c2081e4a-c6b7-4730-be59-bc728b90ecaa?source=cve
Get alerted when CVE-2024-5770 or the next vulnerability affects your stack