What’s Vulnerable › Vulnerabilities
CVE-2024-57792: power: supply: gpio-charger: Fix set charge current limits
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-11 · updated 2026-08-04
Description
In the Linux kernel, the following vulnerability has been resolved: power: supply: gpio-charger: Fix set charge current limits Fix set charge current limits for devices which allow to set the lowest charge current limit to be greater zero. If requested charge current limit is below lowest limit, the index equals current_limit_map_size which leads to accessing memory beyond allocated memory.
Affected products
- Linux kernel: from 5.10 before 5.10.233; from 5.11 before 5.15.176; from 5.16 before 6.1.123; from 6.2 before 6.6.69; from 6.7 before 6.12.8; 6.13-rc1, 6.13-rc2, 6.13-rc3, 6.13-rc4 — fixed in 5.10.233, 5.15.176, 6.1.123, 6.12.8, 6.6.69
How to fix
Upgrade to a fixed version: Linux kernel 5.10.233, 5.15.176, 6.1.123, 6.12.8. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/13eb3cae1d8e23cce96c095abe34da8028c09ac5
- https://git.kernel.org/stable/c/6abbbd8286b6f944eecf3c74444c138590135211
- https://git.kernel.org/stable/c/afc6e39e824ad0e44b2af50a97885caec8d213d1
- https://git.kernel.org/stable/c/b29c7783ac1fe36d639c089cf471ac7a46df05f0
- https://git.kernel.org/stable/c/c3703d9340ca2820e1ac63256f4b423ea8559831
- https://git.kernel.org/stable/c/f6279a98db132da0cfff18712a1b06478c32007f
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-57792 or the next vulnerability affects your stack