What’s Vulnerable › Vulnerabilities
CVE-2024-57804: scsi: mpi3mr: Fix corrupt config pages PHY state is switched in sysfs
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-11 · updated 2026-10-30
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: mpi3mr: Fix corrupt config pages PHY state is switched in sysfs The driver, through the SAS transport, exposes a sysfs interface to enable/disable PHYs in a controller/expander setup. When multiple PHYs are disabled and enabled in rapid succession, the persistent and current config pages related to SAS IO unit/SAS Expander pages could get corrupted. Use separate memory for each config request.
Affected products
- Linux kernel: from 6.1 before 6.12.8; 6.13-rc1 — fixed in 6.12.8
- Linux: 6.1 — fixed in 6.13
How to fix
Upgrade to a fixed version: Linux kernel 6.12.8; Linux 6.13. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/711201a8b8334a397440ac0b859df0054e174bc9
- https://git.kernel.org/stable/c/869fdc6f0606060301aef648231e186c7c542f5a
- https://git.kernel.org/stable/c/90dffa3cec53c0d1af7813a2603f740730c4417e
- https://git.kernel.org/stable/c/d7dade716905b189f17cc1601cbb4b421a811a28
Get alerted when CVE-2024-57804 or the next vulnerability affects your stack