What’s Vulnerable › Vulnerabilities
CVE-2024-5784: Tutor LMS Pro <= 2.7.2 - Missing Authorization to Authenticated (Subscriber+) Insecure Direct Object Reference
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-30 · updated 2026-06-17
- Weakness: CWE-862
Description
The Tutor LMS Pro plugin for WordPress is vulnerable to unauthorized administrative actions execution due to a missing capability checks on multiple functions like treport_quiz_atttempt_delete and tutor_gc_class_action in all versions up to, and including, 2.7.2. This makes it possible for authenticated attackers, with the subscriber-level access and above, to preform an administrative actions on the site, like comments, posts or users deletion, viewing notifications, etc.
Affected products
- themeum Tutor LMS – eLearning and online course solution: before 2.7.3 — fixed in 2.7.3
How to fix
Upgrade to a fixed version: themeum Tutor LMS – eLearning and online course solution 2.7.3. Check the vendor advisory for mitigations.
References
- https://tutorlms.com/releases/id/299/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/aa5c23ed-7239-40e1-a795-1ae8d4c2d6c8?source=cve
Get alerted when CVE-2024-5784 or the next vulnerability affects your stack