What’s Vulnerable › Vulnerabilities
CVE-2024-5787: PowerPack Addons for Elementor (Free Widgets, Extensions and Templates) <= 2.7.20 - Authenticated (Contributor+) Stored Cross-Site Scripting via Link Effects Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-13 · updated 2026-06-17
- Weakness: CWE-79
Description
The PowerPack Addons for Elementor (Free Widgets, Extensions and Templates) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'url' attribute within the plugin's Link Effects widget in all versions up to, and including, 2.7.20 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- ideaboxcreations PowerPack Addons for Elementor (Free Widgets, Extensions and Templates): before 2.7.21 — fixed in 2.7.21
How to fix
Upgrade to a fixed version: ideaboxcreations PowerPack Addons for Elementor (Free Widgets, Extensions and Templates) 2.7.21. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/powerpack-lite-for-elementor/tags/2.7.20/modules/link-effects/widgets/link-effects.php#L482
- https://plugins.trac.wordpress.org/changeset/3101651/#file331
- https://wordpress.org/plugins/powerpack-lite-for-elementor/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ce55230e-8c9e-41aa-b107-16c5988d1feb?source=cve
- https://plugins.trac.wordpress.org/browser/powerpack-lite-for-elementor/tags/2.7.20/modules/link-effects/widgets/link-effects.php#L482
- https://plugins.trac.wordpress.org/changeset/3101651/#file331
- https://wordpress.org/plugins/powerpack-lite-for-elementor/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ce55230e-8c9e-41aa-b107-16c5988d1feb?source=cve
Get alerted when CVE-2024-5787 or the next vulnerability affects your stack