What’s Vulnerable › Vulnerabilities
CVE-2024-57872: scsi: ufs: pltfrm: Dellocate HBA during ufshcd_pltfrm_remove()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-11 · updated 2026-06-17
- Weakness: CWE-401
Description
In the Linux kernel, the following vulnerability has been resolved: scsi: ufs: pltfrm: Dellocate HBA during ufshcd_pltfrm_remove() This will ensure that the scsi host is cleaned up properly using scsi_host_dev_release(). Otherwise, it may lead to memory leaks.
Affected products
- Linux kernel: from 3.10 before 6.12.5; 6.13-rc1 — fixed in 6.12.5
How to fix
Upgrade to a fixed version: Linux kernel 6.12.5. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/897df60c16d54ad515a3d0887edab5c63da06d1f
- https://git.kernel.org/stable/c/cd188519d2467ab4c2141587b0551ba030abff0e
Get alerted when CVE-2024-57872 or the next vulnerability affects your stack