What’s Vulnerable › Vulnerabilities
CVE-2024-57890: RDMA/uverbs: Prevent integer overflow issue
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-15 · updated 2026-06-17
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: RDMA/uverbs: Prevent integer overflow issue In the expression "cmd.wqe_size * cmd.wr_count", both variables are u32 values that come from the user so the multiplication can lead to integer wrapping. Then we pass the result to uverbs_request_next_ptr() which also could potentially wrap. The "cmd.sge_count * sizeof(struct ib_uverbs_sge)" multiplication can also overflow on 32bit systems although it's fine on 64bit systems. This patch does two things. First, I've re-arranged the condition in uverbs_request_next_ptr() so that the use controlled variable "len" is on one side of the comparison by itself without any math. Then I've modified all the callers to use size_mul() for the multiplications.
Affected products
- Linux kernel: from 2.6.15 before 5.4.289; from 5.5 before 5.10.233; from 5.11 before 5.15.176; from 5.16 before 6.1.124; from 6.2 before 6.6.70; from 6.7 before 6.12.9 — fixed in 5.10.233, 5.15.176, 5.4.289, 6.1.124, 6.12.9, 6.6.70
How to fix
Upgrade to a fixed version: Linux kernel 5.10.233, 5.15.176, 5.4.289, 6.1.124. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/346db03e9926ab7117ed9bf19665699c037c773c
- https://git.kernel.org/stable/c/42a6eb4ed7a9a41ba0b83eb0c7e0225b5fca5608
- https://git.kernel.org/stable/c/b3ef4ae713360501182695dd47d6b4f6e1a43eb8
- https://git.kernel.org/stable/c/b92667f755749cf10d9ef1088865c555ae83ffb7
- https://git.kernel.org/stable/c/c2f961c46ea0e5274c5c320d007c2dd949cf627a
- https://git.kernel.org/stable/c/c57721b24bd897338a81a0ca5fff41600f0f1ad1
- https://git.kernel.org/stable/c/d0257e089d1bbd35c69b6c97ff73e3690ab149a9
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-57890 or the next vulnerability affects your stack