What’s Vulnerable › Vulnerabilities
CVE-2024-5790: Happy Addons for Elementor <= 3.11.1 - Authenticated (Contributor+) Stored Cross-Site Scripting via Gradient Heading Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Happy Addons for Elementor plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘url’ attribute within the plugin's Gradient Heading widget in all versions up to, and including, 3.11.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- weDevs Happy Addons for Elementor: before 3.11.2 — fixed in 3.11.2
How to fix
Upgrade to a fixed version: weDevs Happy Addons for Elementor 3.11.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/happy-elementor-addons/tags/3.11.0/widgets/gradient-heading/widget.php#L260
- https://plugins.trac.wordpress.org/changeset/3108597/#file575
- https://wordpress.org/plugins/happy-elementor-addons/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6d1b948a-7a7e-4bdf-af1d-559f34d4baa3?source=cve
- https://plugins.trac.wordpress.org/browser/happy-elementor-addons/tags/3.11.0/widgets/gradient-heading/widget.php#L260
- https://plugins.trac.wordpress.org/changeset/3108597/#file575
- https://wordpress.org/plugins/happy-elementor-addons/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/6d1b948a-7a7e-4bdf-af1d-559f34d4baa3?source=cve
Get alerted when CVE-2024-5790 or the next vulnerability affects your stack