What’s Vulnerable › Vulnerabilities
CVE-2024-57916: misc: microchip: pci1xxxx: Resolve kernel panic during GPIO IRQ handling
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-19 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: misc: microchip: pci1xxxx: Resolve kernel panic during GPIO IRQ handling Resolve kernel panic caused by improper handling of IRQs while accessing GPIO values. This is done by replacing generic_handle_irq with handle_nested_irq.
Affected products
- Linux kernel: from 6.1 before 6.1.125; from 6.2 before 6.6.72; from 6.7 before 6.12.10; 6.13-rc1, 6.13-rc2, 6.13-rc3, 6.13-rc4, 6.13-rc5, 6.13-rc6 — fixed in 6.1.125, 6.12.10, 6.6.72
How to fix
Upgrade to a fixed version: Linux kernel 6.1.125, 6.12.10, 6.6.72. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/194f9f94a5169547d682e9bbcc5ae6d18a564735
- https://git.kernel.org/stable/c/25692750c0259c5b65afec467d97201a485e8a00
- https://git.kernel.org/stable/c/47d3749ec0cb56b7b98917c190a8c10cb54216fd
- https://git.kernel.org/stable/c/79aef6187e16b2d32307c8ff610e9e04f7f86e1f
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
Get alerted when CVE-2024-57916 or the next vulnerability affects your stack