What’s Vulnerable › Vulnerabilities
CVE-2024-57931: selinux: ignore unknown extended permissions
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-21 · updated 2026-06-17
Description
In the Linux kernel, the following vulnerability has been resolved: selinux: ignore unknown extended permissions When evaluating extended permissions, ignore unknown permissions instead of calling BUG(). This commit ensures that future permissions can be added without interfering with older kernels.
Affected products
- Linux kernel: from 4.3 before 5.4.289; from 5.5 before 5.10.233; from 5.11 before 5.15.176; from 5.16 before 6.1.124; from 6.2 before 6.6.70; from 6.7 before 6.12.9 — fixed in 5.10.233, 5.15.176, 5.4.289, 6.1.124, 6.12.9, 6.6.70
How to fix
Upgrade to a fixed version: Linux kernel 5.10.233, 5.15.176, 5.4.289, 6.1.124. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/712137b177b45f255ce5687e679d950fcb218256
- https://git.kernel.org/stable/c/900f83cf376bdaf798b6f5dcb2eae0c822e908b6
- https://git.kernel.org/stable/c/c1dbd28a079553de0023e1c938c713efeeee400f
- https://git.kernel.org/stable/c/c79324d42fa48372e0acb306a2761cc642bd4db0
- https://git.kernel.org/stable/c/efefe36c03a73bb81c0720ce397659a5051b73fa
- https://git.kernel.org/stable/c/f45a77dd24ae9ddb474303ec3975c376bd99fc51
- https://git.kernel.org/stable/c/f70e4b9ec69d9a74b84c17767a9a4eda8c901021
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-57931 or the next vulnerability affects your stack