What’s Vulnerable › Vulnerabilities
CVE-2024-57938: net/sctp: Prevent autoclose integer overflow in sctp_association_init()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-21 · updated 2026-06-17
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: net/sctp: Prevent autoclose integer overflow in sctp_association_init() While by default max_autoclose equals to INT_MAX / HZ, one may set net.sctp.max_autoclose to UINT_MAX. There is code in sctp_association_init() that can consequently trigger overflow.
Affected products
- Linux kernel: from 3.13 before 5.4.289; from 5.5 before 5.10.233; from 5.11 before 5.15.176; from 5.16 before 6.1.124; from 6.2 before 6.6.70; from 6.7 before 6.12.9 — fixed in 5.10.233, 5.15.176, 5.4.289, 6.1.124, 6.12.9, 6.6.70
How to fix
Upgrade to a fixed version: Linux kernel 5.10.233, 5.15.176, 5.4.289, 6.1.124. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/081bdb3a31674339313c6d702af922bc29de2c53
- https://git.kernel.org/stable/c/2297890b778b0e7c8200d6818154f7e461d78e94
- https://git.kernel.org/stable/c/271f031f4c31c07e2a85a1ba2b4c8e734909a477
- https://git.kernel.org/stable/c/4e86729d1ff329815a6e8a920cb554a1d4cb5b8d
- https://git.kernel.org/stable/c/7af63ef5fe4d480064eb22583b24ffc8b408183a
- https://git.kernel.org/stable/c/94b7ed0a4896420988e1776942f0a3f67167873e
- https://git.kernel.org/stable/c/f9c3adb083d3278f065a83c3f667f1246c74c31f
- https://lists.debian.org/debian-lts-announce/2025/03/msg00001.html
- https://lists.debian.org/debian-lts-announce/2025/03/msg00002.html
Get alerted when CVE-2024-57938 or the next vulnerability affects your stack