What’s Vulnerable › Vulnerabilities

CVE-2024-5795: Denial of Service vulnerability was identified in GitHub Enterprise Server that allowed resource exhaustion

Description

A Denial of Service vulnerability was identified in GitHub Enterprise Server that allowed an attacker to cause unbounded resource exhaustion by sending a large payload to the Git server. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in version 3.13.1, 3.12.6, 3.11.12, 3.10.14, and 3.9.17. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

How to fix

Upgrade to a fixed version: GitHub Enterprise Server 3.10.14, 3.11.12, 3.12.6, 3.9.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-5795 or the next vulnerability affects your stack