What’s Vulnerable › Vulnerabilities
CVE-2024-57965
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-01-29 · updated 2026-06-17
- Weakness: CWE-346
Description
In axios before 1.7.8, lib/helpers/isURLSameOrigin.js does not use a URL object when determining an origin, and has a potentially unwanted setAttribute('href',href) call. NOTE: some parties feel that the code change only addresses a warning message from a SAST tool and does not fix a vulnerability.
Affected products
- axios: before 1.7.8 — fixed in 1.7.8
How to fix
Upgrade to a fixed version: axios 1.7.8. Check the vendor advisory for mitigations.
References
- https://github.com/axios/axios/commit/0a8d6e19da5b9899a2abafaaa06a75ee548597db
- https://github.com/axios/axios/issues/6351
- https://github.com/axios/axios/pull/6714
- https://github.com/axios/axios/releases/tag/v1.7.8
Get alerted when CVE-2024-57965 or the next vulnerability affects your stack