What’s Vulnerable › Vulnerabilities
CVE-2024-58014: wifi: brcmsmac: add gain range check to wlc_phy_iqcal_gainparams_nphy()
- Severity: high (CVSS 7.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-10-15
- Weakness: CWE-125
Description
In the Linux kernel, the following vulnerability has been resolved: wifi: brcmsmac: add gain range check to wlc_phy_iqcal_gainparams_nphy() In 'wlc_phy_iqcal_gainparams_nphy()', add gain range check to WARN() instead of possible out-of-bounds 'tbl_iqcal_gainparams_nphy' access. Compile tested only. Found by Linux Verification Center (linuxtesting.org) with SVACE.
Affected products
- Linux kernel: from 3.2 before 5.4.291; from 5.5 before 5.10.235; from 5.11 before 5.15.179; from 5.16 before 6.1.129; from 6.2 before 6.6.78; from 6.7 before 6.12.14 — fixed in 5.10.235, 5.15.179, 5.4.291, 6.1.129, 6.12.14, 6.13.3
How to fix
Upgrade to a fixed version: Linux kernel 5.10.235, 5.15.179, 5.4.291, 6.1.129. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/093286c33409bf38896f2dab0c0bb6ca388afb33
- https://git.kernel.org/stable/c/0a457223cb2b9ca46bae7de387d0f4c093b0220d
- https://git.kernel.org/stable/c/13ef16c4fe384b1e70277bbe1d87934ee6c81e12
- https://git.kernel.org/stable/c/3f4a0948c3524ae50f166dbc6572a3296b014e62
- https://git.kernel.org/stable/c/6f6e293246dc1f5b2b6b3d0f2d757598489cda79
- https://git.kernel.org/stable/c/ada9df08b3ef683507e75b92f522fb659260147f
- https://git.kernel.org/stable/c/c27ce584d274f6ad3cba2294497de824a3c66646
- https://git.kernel.org/stable/c/d280a12e9b87819a8a209639d600b48a2d6d65dc
- https://lists.debian.org/debian-lts-announce/2025/03/msg00028.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://cert-portal.siemens.com/productcert/html/ssa-265688.html
- https://cert-portal.siemens.com/productcert/html/ssa-784472.html
Get alerted when CVE-2024-58014 or the next vulnerability affects your stack