What’s Vulnerable › Vulnerabilities
CVE-2024-58017: printk: Fix signed integer overflow when defining LOG_BUF_LEN_MAX
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-02-27 · updated 2026-10-15
- Weakness: CWE-190
Description
In the Linux kernel, the following vulnerability has been resolved: printk: Fix signed integer overflow when defining LOG_BUF_LEN_MAX Shifting 1 << 31 on a 32-bit int causes signed integer overflow, which leads to undefined behavior. To prevent this, cast 1 to u32 before performing the shift, ensuring well-defined behavior. This change explicitly avoids any potential overflow by ensuring that the shift occurs on an unsigned 32-bit integer.
Affected products
- Linux kernel: before 6.1.129; from 6.2 before 6.6.78; from 6.7 before 6.12.14; from 6.13 before 6.13.3 — fixed in 6.1.129, 6.12.14, 6.13.3, 6.6.78
How to fix
Upgrade to a fixed version: Linux kernel 6.1.129, 6.12.14, 6.13.3, 6.6.78. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3d6f83df8ff2d5de84b50377e4f0d45e25311c7a
- https://git.kernel.org/stable/c/404e5fd918a0b14abec06c7eca128f04c9b98e41
- https://git.kernel.org/stable/c/4a2c4e7265b8eed83c25d86d702cea06493cab18
- https://git.kernel.org/stable/c/4acf6bab775dbd22a9a799030a808a7305e01d63
- https://git.kernel.org/stable/c/54c14022fa2ba427dc543455c2cf9225903a7174
- https://git.kernel.org/stable/c/9a6d43844de2479a3ff8d674c3e2a16172e01598
- https://git.kernel.org/stable/c/bb8ff054e19fe27f4e5eaac1b05e462894cfe9b1
- https://git.kernel.org/stable/c/dfb7b179741ee09506dc7719d92f9e1cea01f10e
- https://lists.debian.org/debian-lts-announce/2025/03/msg00028.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://cert-portal.siemens.com/productcert/html/ssa-265688.html
- https://cert-portal.siemens.com/productcert/html/ssa-784472.html
Get alerted when CVE-2024-58017 or the next vulnerability affects your stack