What’s Vulnerable › Vulnerabilities
CVE-2024-58085: tomoyo: don't emit warning in tomoyo_write_control()
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-06 · updated 2026-10-15
Description
In the Linux kernel, the following vulnerability has been resolved: tomoyo: don't emit warning in tomoyo_write_control() syzbot is reporting too large allocation warning at tomoyo_write_control(), for one can write a very very long line without new line character. To fix this warning, I use __GFP_NOWARN rather than checking for KMALLOC_MAX_SIZE, for practically a valid line should be always shorter than 32KB where the "too small to fail" memory-allocation rule applies. One might try to write a valid line that is longer than 32KB, but such request will likely fail with -ENOMEM. Therefore, I feel that separately returning -EINVAL when a line is longer than KMALLOC_MAX_SIZE is redundant. There is no need to distinguish over-32KB and over-KMALLOC_MAX_SIZE.
Affected products
- Linux kernel: before 5.4.291; from 5.5 before 5.10.235; from 5.11 before 5.15.179; from 5.16 before 6.1.129; from 6.2 before 6.6.78; from 6.7 before 6.12.14 — fixed in 5.10.235, 5.15.179, 5.4.291, 6.1.129, 6.12.14, 6.13.3
How to fix
Upgrade to a fixed version: Linux kernel 5.10.235, 5.15.179, 5.4.291, 6.1.129. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/3df7546fc03b8f004eee0b9e3256369f7d096685
- https://git.kernel.org/stable/c/414705c0303350d139b1dc18f329fe47dfb642dd
- https://git.kernel.org/stable/c/a01c200fa7eb59da4d2dbbb48b61f4a0d196c09f
- https://git.kernel.org/stable/c/b2bd5857a0d6973ebbcb4d9831ddcaebbd257be1
- https://git.kernel.org/stable/c/c67efabddc73171c7771d3ffe4ffa1e503ee533e
- https://git.kernel.org/stable/c/c9382f380e8d09209b8e5c0def0545852168be25
- https://git.kernel.org/stable/c/f6b37b3e12de638753bce79a2858070b9c4a4ad3
- https://git.kernel.org/stable/c/fe1c021eb03dae0dc9dce55e81f77a60e419a27a
- https://lists.debian.org/debian-lts-announce/2025/03/msg00028.html
- https://lists.debian.org/debian-lts-announce/2025/05/msg00030.html
- https://cert-portal.siemens.com/productcert/html/ssa-265688.html
Get alerted when CVE-2024-58085 or the next vulnerability affects your stack