What’s Vulnerable › Vulnerabilities
CVE-2024-58087: ksmbd: fix racy issue from session lookup and expire
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-12 · updated 2026-08-04
- Weakness: CWE-667
Description
In the Linux kernel, the following vulnerability has been resolved: ksmbd: fix racy issue from session lookup and expire Increment the session reference count within the lock for lookup to avoid racy issue with session expire.
Affected products
- Linux kernel: from 5.15.145 before 5.15.176; from 6.1.29 before 6.1.121; from 6.2.16 before 6.3; from 6.3.2 before 6.4; from 6.7 before 6.12.6; 6.13-rc1, 6.13-rc2 — fixed in 5.15.176, 6.1.121, 6.12.6, 6.3, 6.4
How to fix
Upgrade to a fixed version: Linux kernel 5.15.176, 6.1.121, 6.12.6, 6.3. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/stable/c/2107ab40629aeabbec369cf34b8cf0f288c3eb1b
- https://git.kernel.org/stable/c/37a0e2b362b3150317fb6e2139de67b1e29ae5ff
- https://git.kernel.org/stable/c/450a844c045ff0895d41b05a1cbe8febd1acfcfd
- https://git.kernel.org/stable/c/a39e31e22a535d47b14656a7d6a893c7f6cf758c
- https://git.kernel.org/stable/c/b95629435b84b9ecc0c765995204a4d8a913ed52
- https://www.zerodayinitiative.com/advisories/ZDI-25-100/
Get alerted when CVE-2024-58087 or the next vulnerability affects your stack