What’s Vulnerable › Vulnerabilities
CVE-2024-58102
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-11 · updated 2026-06-17
- Weakness: CWE-674
Description
An issue was discovered in Datalust Seq before 2024.3.13545. An insecure default parsing depth limit allows stack consumption when parsing user-supplied queries containing deeply nested expressions.
Affected products
- Datalust Seq: before 2024.3.13545 — fixed in 2024.3.13545
How to fix
Upgrade to a fixed version: Datalust Seq 2024.3.13545. Check the vendor advisory for mitigations.
References
- https://datalust.co/seq
- https://github.com/datalust/seq-tickets/issues/2086
- https://github.com/datalust/seq-tickets/issues/2367
Get alerted when CVE-2024-58102 or the next vulnerability affects your stack