What’s Vulnerable › Vulnerabilities
CVE-2024-58103
- Severity: medium (CVSS 5.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-16 · updated 2026-06-17
- Weakness: CWE-674
Description
Square Wire before 5.2.0 does not enforce a recursion limit on nested groups in ByteArrayProtoReader32.kt and ProtoReader.kt.
Affected products
- square wire: before 5.2.0 — fixed in 5.2.0
How to fix
Upgrade to a fixed version: square wire 5.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/square/wire/commit/b90e60c09befaff836a2fc2ee4d678451b2ec75d
- https://github.com/square/wire/compare/5.1.0...5.2.0
Get alerted when CVE-2024-58103 or the next vulnerability affects your stack