What’s Vulnerable › Vulnerabilities
CVE-2024-5812: Smart Rule Overwrite Bypass in BeyondInsight PasswordSafe
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-11 · updated 2026-06-17
- Weakness: CWE-290
Description
A low severity vulnerability in BIPS has been identified where an attacker with high privileges or a compromised high privilege account can overwrite Read-Only smart rules via a specially crafted API request.
Affected products
- BeyondTrust BeyondInsight PasswordSafe: from 23.2 before 23.2.0.1293; from 23.3 before 23.3.0.959; 24.1 — fixed in 23.2.0.1293, 23.3.0.959
How to fix
Upgrade to a fixed version: BeyondTrust BeyondInsight PasswordSafe 23.2.0.1293, 23.3.0.959. Check the vendor advisory for mitigations.
References
- https://www.beyondtrust.com/trust-center/security-advisories/bt24-07
- https://www.beyondtrust.com/trust-center/security-advisories/bt24-07
Get alerted when CVE-2024-5812 or the next vulnerability affects your stack