What’s Vulnerable › Vulnerabilities
CVE-2024-58128
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-28 · updated 2026-06-22
- Weakness: CWE-79
Description
In MISP before 2.4.193, menu_custom_right_link parameters can be set via the UI (i.e., without using the CLI) and thus attackers with admin privileges can conduct XSS attacks via a global menu link.
Affected products
- MISP: before 2.4.193 — fixed in 2.4.193
How to fix
Upgrade to a fixed version: MISP 2.4.193. Check the vendor advisory for mitigations.
References
- https://github.com/MISP/MISP/commit/33a1eb66408e16a7535b2bae48303efd9501a26a
- https://github.com/MISP/MISP/releases/tag/v2.4.193
Get alerted when CVE-2024-58128 or the next vulnerability affects your stack