What’s Vulnerable › Vulnerabilities
CVE-2024-58132
- Severity: medium (CVSS 4.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-06 · updated 2026-06-17
- Weakness: CWE-821
Description
In chainmaker-go (aka ChainMaker) before 2.3.6, multiple updates to a single node's configuration can cause other normal nodes to perform concurrent read and write operations on a map, leading to a panic.
Affected products
- chainmaker-go: before 2.3.6 — fixed in 2.3.6
How to fix
Upgrade to a fixed version: chainmaker-go 2.3.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-58132 or the next vulnerability affects your stack