What’s Vulnerable › Vulnerabilities
CVE-2024-58133
- Severity: medium (CVSS 4.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-06 · updated 2026-06-17
- Weakness: CWE-821
Description
In chainmaker-go (aka ChainMaker) before 2.4.0, when making frequent updates to a node's configuration file and restarting this node, concurrent writes by logger.go to a map are mishandled. Creating other logs simultaneously can lead to a read-write conflict and panic.
Affected products
- chainmaker-go: before 2.4.0 — fixed in 2.4.0
How to fix
Upgrade to a fixed version: chainmaker-go 2.4.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-58133 or the next vulnerability affects your stack