What’s Vulnerable › Vulnerabilities

CVE-2024-5816: Improper authorization allows persistent access in GitHub Enterprise Server

Description

An Incorrect Authorization vulnerability was identified in GitHub Enterprise Server that allowed a suspended GitHub App to retain access to the repository via a scoped user access token. This was only exploitable in public repositories while private repositories were not impacted. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in versions 3.9.17, 3.10.14, 3.11.12, 3.12.6, 3.13.1. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

How to fix

Upgrade to a fixed version: GitHub Enterprise Server 3.10.14, 3.11.12, 3.12.6, 3.9.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-5816 or the next vulnerability affects your stack