What’s Vulnerable › Vulnerabilities

CVE-2024-5817: Improper authorization allows read access to issue content in GitHub Enterprise Server

Description

An Incorrect Authorization vulnerability was identified in GitHub Enterprise Server that allowed read access to issue content via GitHub Projects. This was only exploitable in internal repositories and required the attacker to have access to the corresponding project board. This vulnerability affected all versions of GitHub Enterprise Server prior to 3.14 and was fixed in versions 3.13.1, 3.12.6, 3.11.12, 3.10.14, and 3.9.17. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

How to fix

Upgrade to a fixed version: GitHub Enterprise Server 3.10.14, 3.11.12, 3.12.6, 3.9.17. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-5817 or the next vulnerability affects your stack