What’s Vulnerable › Vulnerabilities
CVE-2024-5818: Royal Elementor Addons and Templates <= 1.3.980 - Authenticated (Contributor+) DOM-Based Stored Cross-Site Scripting via Magazine Grid/Slider Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-24 · updated 2026-06-17
- Weakness: CWE-79
Description
The Royal Elementor Addons and Templates plugin for WordPress is vulnerable to Stored DOM-based Cross-Site Scripting via the plugin's Magazine Grid/Slider widget in all versions up to, and including, 1.3.980 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor: before 1.3.981 — fixed in 1.3.981
How to fix
Upgrade to a fixed version: wproyal Royal Addons for Elementor – Addons and Templates Kit for Elementor 1.3.981. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3121073/royal-elementor-addons
- https://www.wordfence.com/threat-intel/vulnerabilities/id/83a0150d-a9fa-4cc2-8fe8-a429747a9964?source=cve
- https://plugins.trac.wordpress.org/changeset/3121073/royal-elementor-addons
- https://www.wordfence.com/threat-intel/vulnerabilities/id/83a0150d-a9fa-4cc2-8fe8-a429747a9964?source=cve
Get alerted when CVE-2024-5818 or the next vulnerability affects your stack