What’s Vulnerable › Vulnerabilities
CVE-2024-58250
- Severity: critical (CVSS 9.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-04-22 · updated 2026-06-17
- Weakness: CWE-426
Description
The passprompt plugin in pppd in ppp before 2.5.2 mishandles privileges.
Affected products
- ppp: before 2.5.2 — fixed in 2.5.2
How to fix
Upgrade to a fixed version: ppp 2.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/ppp-project/ppp/commit/0a66ad22e54c72690ec2a29a019767c55c5281fc
- https://github.com/ppp-project/ppp/compare/v2.5.1...v2.5.2
- https://ppp.samba.org
Get alerted when CVE-2024-58250 or the next vulnerability affects your stack