What’s Vulnerable › Vulnerabilities
CVE-2024-58253
- Severity: low (CVSS 2.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-05-02 · updated 2026-06-17
- Weakness: CWE-843
Description
In the obfstr crate before 0.4.4 for Rust, the obfstr! argument type is not restricted to string slices, leading to invalid UTF-8 conversion that produces an invalid value.
Affected products
- CasualX obfstr: before 0.4.4 — fixed in 0.4.4
How to fix
Upgrade to a fixed version: CasualX obfstr 0.4.4. Check the vendor advisory for mitigations.
References
- https://github.com/CasualX/obfstr/compare/v0.4.3...v0.4.4
- https://github.com/CasualX/obfstr/issues/60
Get alerted when CVE-2024-58253 or the next vulnerability affects your stack