What’s Vulnerable › Vulnerabilities
CVE-2024-58258
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 22.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-07-13 · updated 2026-06-17
- Weakness: CWE-94
Description
SugarCRM before 13.0.4 and 14.x before 14.0.1 allows SSRF in the API module because a limited type of code injection can occur.
Affected products
- SugarCRM: before 13.0.4; from 14 before 14.0.1 — fixed in 13.0.4, 14.0.1
How to fix
Upgrade to a fixed version: SugarCRM 13.0.4, 14.0.1. Check the vendor advisory for mitigations.
References
- https://support.sugarcrm.com/resources/security/sugarcrm-sa-2024-059/
- http://seclists.org/fulldisclosure/2025/Jul/21
Get alerted when CVE-2024-58258 or the next vulnerability affects your stack