What’s Vulnerable › Vulnerabilities
CVE-2024-58259: Rancher affected by unauthenticated Denial of Service
- Severity: high (CVSS 8.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-09-02 · updated 2026-06-17
- Weakness: CWE-770
Description
A vulnerability has been identified within Rancher Manager in which it did not enforce request body size limits on certain public (unauthenticated) and authenticated API endpoints. This allows a malicious user to exploit this by sending excessively large payloads, which are fully loaded into memory during processing, leading to Denial of Service (DoS).
Affected products
- SUSE Rancher: from 2.12.0 before 2.12.1; from 2.11.0 before 2.11.5; from 2.10.0 before 2.10.9; from 2.9.0 before 2.9.11; before 0.0.0-20250813072957-aee95d4e2a41 — fixed in 0.0.0-20250813072957-aee95d4e2a41, 2.10.9, 2.11.5, 2.12.1, 2.9.11
How to fix
Upgrade to a fixed version: SUSE Rancher 0.0.0-20250813072957-aee95d4e2a41, 2.10.9, 2.11.5, 2.12.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2024-58259
- https://github.com/rancher/rancher/security/advisories/GHSA-4h45-jpvh-6p5j
Get alerted when CVE-2024-58259 or the next vulnerability affects your stack