What’s Vulnerable › Vulnerabilities
CVE-2024-58260: Rancher update on users can deny the service to the admin
- Severity: high (CVSS 7.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-02 · updated 2026-06-17
- Weakness: CWE-863
Description
A vulnerability has been identified within Rancher Manager where a missing server-side validation on the `.username` field in Rancher can allow users with update permissions on other User resources to cause denial of access for targeted accounts.
Affected products
- SUSE Rancher: from 2.12.0 before 2.12.2; from 2.11.0 before 2.11.6; from 2.10.0 before 2.10.10; from 2.9.0 before 2.9.12 — fixed in 2.10.10, 2.11.6, 2.12.2, 2.9.12
How to fix
Upgrade to a fixed version: SUSE Rancher 2.10.10, 2.11.6, 2.12.2, 2.9.12. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2024-58260
- https://github.com/rancher/rancher/security/advisories/GHSA-q82v-h4rq-5c86
Get alerted when CVE-2024-58260 or the next vulnerability affects your stack