What’s Vulnerable › Vulnerabilities

CVE-2024-58263

Description

The cosmwasm-std crate before 2.0.2 for Rust allows integer overflows that cause incorrect contract calculations.

Affected products

How to fix

Upgrade to a fixed version: cosmwasm-std 1.4.4, 1.5.4, 2.0.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-58263 or the next vulnerability affects your stack