What’s Vulnerable › Vulnerabilities
CVE-2024-58267: Rancher CLI SAML authentication is vulnerable to phishing attacks
- Severity: high (CVSS 8.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-10-02 · updated 2026-06-17
- Weakness: CWE-345
Description
A vulnerability has been identified within Rancher Manager whereby the SAML authentication from the Rancher CLI tool is vulnerable to phishing attacks. The custom authentication protocol for SAML-based providers can be abused to steal Rancher’s authentication tokens.
Affected products
- SUSE Rancher: from 2.12.0 before 2.12.2; from 2.11.0 before 2.11.6; from 2.10.0 before 2.10.10; from 2.9.0 before 2.9.12 — fixed in 2.10.10, 2.11.6, 2.12.2, 2.9.12
How to fix
Upgrade to a fixed version: SUSE Rancher 2.10.10, 2.11.6, 2.12.2, 2.9.12. Check the vendor advisory for mitigations.
References
- https://bugzilla.suse.com/show_bug.cgi?id=CVE-2024-58267
- https://github.com/rancher/rancher/security/advisories/GHSA-v3vj-5868-2ch2
Get alerted when CVE-2024-58267 or the next vulnerability affects your stack