What’s Vulnerable › Vulnerabilities
CVE-2024-58304: SPA-CART CMS < 2.0.0 Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-12-11 · updated 2026-10-27
- Weakness: CWE-79
Description
SPA-CART CMS before 2.0.0 contains a stored cross-site scripting vulnerability in the product description parameter that allows authenticated administrators to inject malicious scripts. Attackers can submit JavaScript payloads through the 'descr' parameter in the product edit form to execute arbitrary code in administrative users' browsers.
Affected products
- SPA-CART CMS: before 2.0.0 — fixed in 2.0.0
How to fix
Upgrade to a fixed version: SPA-CART CMS 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/olegkhorev/php-spa-cart/releases/tag/v2.0.0
- https://www.exploit-db.com/exploits/51919
- https://www.vulncheck.com/advisories/spa-cart-cms-stored-cross-site-scripting-via-product-description
Get alerted when CVE-2024-58304 or the next vulnerability affects your stack