What’s Vulnerable › Vulnerabilities
CVE-2024-58351: Flowise - Remote Code Execution via overrideConfig Parameter
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-06-20 · updated 2026-10-27
- Weakness: CWE-94
Description
Flowise before 2.1.4 allows configuration to be injected into the Chainflow during execution via the overrideConfig option, supported in both the frontend web integration and the backend Prediction API. Because this feature is enabled by default with no allow-list of permitted variables and relies on vm2 for sandboxing, an attacker can abuse it to achieve remote code execution and sandbox escape, denial of service by crashing the server, server-side request forgery, prompt injection, and server variable and data exfiltration. These issues are self-targeted and do not persist to other users.
Affected products
- FlowiseAI Flowise: before 2.1.4 — fixed in 2.1.4
How to fix
Upgrade to a fixed version: FlowiseAI Flowise 2.1.4. Check the vendor advisory for mitigations.
References
- https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-5cph-wvm9-45gj
- https://www.vulncheck.com/advisories/flowise-remote-code-execution-via-overrideconfig-parameter
Get alerted when CVE-2024-58351 or the next vulnerability affects your stack