What’s Vulnerable › Vulnerabilities
CVE-2024-58353: Cal.com through 4.7.15 Cross-Site Scripting via booking questions
- Severity: high (CVSS 8.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-23 · updated 2026-07-30
- Weakness: CWE-80
Description
Cal.com (repository calcom/cal.diy) in versions <= 4.7.15 is vulnerable to cross-site scripting (XSS) on the publicly accessible single booking view (e.g., /booking/<id>). Booking question (form field) labels are rendered via React's dangerouslySetInnerHTML without proper input sanitization or CSP, so an attacker who can create an event type with a malicious booking question label can inject arbitrary HTML/JavaScript that executes when a victim visits the booking view URL. Self-hosted instances with open registration are particularly at risk. The issue is fixed in version 4.7.16.
Affected products
- calcom cal.diy: through 4.7.15
References
- https://github.com/calcom/cal.diy/commit/00689fda0a30b8f933c096f02c1fe092a4206def
- https://github.com/calcom/cal.diy/security/advisories/GHSA-vgj7-76cw-h6f8
- https://www.vulncheck.com/advisories/cal-com-through-cross-site-scripting-via-booking-questions
- https://github.com/calcom/cal.diy/security/advisories/GHSA-vgj7-76cw-h6f8
Get alerted when CVE-2024-58353 or the next vulnerability affects your stack