What’s Vulnerable › Vulnerabilities
CVE-2024-58358: SurrealDB before 2.1.0 Denial of Service via Nonexistent Role
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-18 · updated 2026-10-27
- Weakness: CWE-248
Description
SurrealDB versions before 2.1.0 contain a denial of service vulnerability in role conversion that allows privileged owner users to define users with nonexistent roles. Attackers can trigger an uncaught panic by signing in with a user assigned an invalid role, crashing the server.
Affected products
- surrealdb: before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: surrealdb 2.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-jc55-246c-r88f
- https://www.vulncheck.com/advisories/surrealdb-before-denial-of-service-via-nonexistent-role
Get alerted when CVE-2024-58358 or the next vulnerability affects your stack