What’s Vulnerable › Vulnerabilities
CVE-2024-58361: SurrealDB before 2.0.4 Denial of Service via Parser Exception
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-18 · updated 2026-10-27
- Weakness: CWE-248
Description
SurrealDB versions before 2.0.4 contain an uncaught exception handling vulnerability in the parser error rendering code when processing empty strings. Authorized clients can execute malformed queries with empty string conversions to record, duration, or datetime types that cause a panic in error rendering, crashing the server.
Affected products
- surrealdb: from 2.0.0 before 2.0.4 — fixed in 2.0.4
How to fix
Upgrade to a fixed version: surrealdb 2.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-qjrv-v6qp-x99x
- https://www.vulncheck.com/advisories/surrealdb-before-denial-of-service-via-parser-exception
Get alerted when CVE-2024-58361 or the next vulnerability affects your stack