What’s Vulnerable › Vulnerabilities

CVE-2024-58363: SurrealDB before 1.5.4 Authentication Bypass via Database Switch

Description

SurrealDB before 1.5.4 and 2.0.0-alpha.1 before 2.0.0-alpha.6 fails to properly validate authentication when a scope user switches databases using the USE clause or use method. Attackers with an authenticated session can impersonate an unrelated user in a different database if a user record with an identical identifier exists, allowing unauthorized actions if permissions rely solely on the $auth parameter.

Affected products

How to fix

Upgrade to a fixed version: surrealdb 1.5.4; surrealdb 1.5.4; surrealdb-core 1.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-58363 or the next vulnerability affects your stack