What’s Vulnerable › Vulnerabilities
CVE-2024-58367: SurrealDB before 2.0.4 Improper Authorization via SELECT Permissions
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-18 · updated 2026-10-27
- Weakness: CWE-285
Description
SurrealDB versions before 2.0.4 fail to properly enforce field permissions during SELECT, UPDATE, and DELETE operations, allowing authorized users to access unauthorized field values through various query techniques. Attackers can exploit SELECT VALUE operations, field aliasing, function arguments, WHERE clause filtering, RETURN BEFORE clauses, and SET clause references to leak protected field contents despite lacking SELECT permissions.
Affected products
- surrealdb: before 2.0.4 — fixed in 2.0.4
How to fix
Upgrade to a fixed version: surrealdb 2.0.4. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-9722-9j67-vjcr
- https://www.vulncheck.com/advisories/surrealdb-before-improper-authorization-via-select-permissions
Get alerted when CVE-2024-58367 or the next vulnerability affects your stack