What’s Vulnerable › Vulnerabilities
CVE-2024-58368: SurrealDB before 1.1.0 Denial of Service via HTTP Headers
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-18 · updated 2026-10-27
- Weakness: CWE-248
Description
SurrealDB versions before 1.1.0 fail to properly parse the ID, DB, and NS headers in HTTP REST API requests containing special characters. Unauthenticated attackers can send crafted HTTP requests with malformed header values to trigger an uncaught exception that crashes the server.
Affected products
- surrealdb: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: surrealdb 1.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-m24x-r6q3-2vp9
- https://www.vulncheck.com/advisories/surrealdb-before-denial-of-service-via-http-headers
Get alerted when CVE-2024-58368 or the next vulnerability affects your stack