What’s Vulnerable › Vulnerabilities
CVE-2024-58369: SurrealDB before 1.1.1 Denial of Service via Global Parameters
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-18 · updated 2026-10-27
- Weakness: CWE-248
Description
SurrealDB versions before 1.1.1 fail to properly validate invocation of custom parameters and functions at root or namespace levels, causing server panic. Authorized clients can invoke these entities at unsupported levels to crash the SurrealDB server, resulting in denial of service.
Affected products
- surrealdb: before 1.1.1 — fixed in 1.1.1
How to fix
Upgrade to a fixed version: surrealdb 1.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-jm4v-58r5-66hj
- https://www.vulncheck.com/advisories/surrealdb-before-denial-of-service-via-global-parameters
Get alerted when CVE-2024-58369 or the next vulnerability affects your stack