What’s Vulnerable › Vulnerabilities
CVE-2024-58370: SurrealDB before 1.1.0 Uncontrolled Recursion Denial of Service
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-07-18 · updated 2026-10-27
- Weakness: CWE-674
Description
SurrealDB versions before 1.1.0 fail to enforce recursion depth limits when parsing nested SurrealQL statements including IF, RELATE, and attribute access idioms. Authorized attackers can submit queries with excessive nesting depth to cause stack overflow and crash the server.
Affected products
- surrealdb: before 1.1.0 — fixed in 1.1.0
How to fix
Upgrade to a fixed version: surrealdb 1.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/surrealdb/surrealdb/security/advisories/GHSA-6r8p-hpg7-825g
- https://www.vulncheck.com/advisories/surrealdb-before-uncontrolled-recursion-denial-of-service
Get alerted when CVE-2024-58370 or the next vulnerability affects your stack