What’s Vulnerable › Vulnerabilities

CVE-2024-58375: OpenTofu before 1.8.3 Secret Variable Leaking via Static Evaluation

Description

OpenTofu versions 1.8.0 through 1.8.2 do not properly restrict sensitive variables and locals when users have opted into static evaluation of module sources, versions, and backend configurations. As a result, values marked as sensitive may be exposed through these configuration elements instead of producing an error. This is fixed in OpenTofu 1.8.3, which adds explicit errors to prevent the use of sensitive values in these contexts.

Affected products

How to fix

Upgrade to a fixed version: opentofu 1.8.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-58375 or the next vulnerability affects your stack