What’s Vulnerable › Vulnerabilities
CVE-2024-58380: PocketMine-MP before 5.11.2 Denial of Service via BookEditPacket
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-09-09 · updated 2026-10-27
- Weakness: CWE-20
Description
PocketMine-MP versions before 5.11.2 contain a denial of service vulnerability in BookEditPacket handling that crashes the server when an invalid inventory slot value is provided. Attackers can send a crafted BookEditPacket with an inventory slot greater than 35 to trigger an unhandled exception and crash the server.
Affected products
- pmmp PocketMine-MP: before 5.11.2 — fixed in 5.11.2
How to fix
Upgrade to a fixed version: pmmp PocketMine-MP 5.11.2. Check the vendor advisory for mitigations.
References
- https://github.com/pmmp/PocketMine-MP/commit/47f011966092f275cc1b11f8de635e89fd9651a7
- https://github.com/pmmp/PocketMine-MP/security/advisories/GHSA-xc7j-wj36-qjfr
- https://www.vulncheck.com/advisories/pocketmine-mp-before-5.11.2-denial-of-service-via-bookeditpacket
Get alerted when CVE-2024-58380 or the next vulnerability affects your stack