What’s Vulnerable › Vulnerabilities

CVE-2024-58386: ZoneMinder 1.37.x Path Traversal via files view

Description

ZoneMinder versions 1.37.0 before 1.38.0 contain a path traversal vulnerability in the files view that allows authenticated users to read arbitrary files. The path parameter is not properly validated before being passed to output_file, enabling attackers with Events view permission to access sensitive files like configuration files containing database credentials.

Affected products

How to fix

Upgrade to a fixed version: zoneminder 1.38.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-58386 or the next vulnerability affects your stack