What’s Vulnerable › Vulnerabilities
CVE-2024-58390: Frappe before 15.41.0 Privilege Escalation via Document Action
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2026-10-12 · updated 2026-10-27
- Weakness: CWE-269
Description
Frappe before 14.81.4 and 15.x before 15.41.0 contains an improper privilege management vulnerability involving a certain document action that permits escalation from the Website User role to System Manager. Authenticated attackers with Website User access can combine this document action with additional steps to obtain administrative System Manager privileges in the Frappe application.
Affected products
- frappe: before 14.81.4; from 15.0.0 before 15.41.0 — fixed in 14.81.4, 15.41.0
How to fix
Upgrade to a fixed version: frappe 14.81.4, 15.41.0. Check the vendor advisory for mitigations.
References
- https://github.com/frappe/frappe/security/advisories/GHSA-gjqf-v2f6-962h
- https://www.vulncheck.com/advisories/frappe-before-15.41.0-privilege-escalation-via-document-action
Get alerted when CVE-2024-58390 or the next vulnerability affects your stack