What’s Vulnerable › Vulnerabilities
CVE-2024-5868: WooCommerce - Social Login <= 2.6.2 - Email Verification due to Insufficient Randomness
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-06-15 · updated 2026-06-17
- Weakness: CWE-330
Description
The WooCommerce - Social Login plugin for WordPress is vulnerable to Email Verification in all versions up to, and including, 2.6.2 via the use of insufficiently random activation code. This makes it possible for unauthenticated attackers to bypass the email verification.
Affected products
- WPWeb WooCommerce - Social Login: before 2.6.3 — fixed in 2.6.3
How to fix
Upgrade to a fixed version: WPWeb WooCommerce - Social Login 2.6.3. Check the vendor advisory for mitigations.
References
- https://codecanyon.net/item/social-login-wordpress-woocommerce-plugin/8495883
- https://www.wordfence.com/threat-intel/vulnerabilities/id/97fbbf5b-d3c7-47ce-b251-ce1fe38af152?source=cve
- https://codecanyon.net/item/social-login-wordpress-woocommerce-plugin/8495883
- https://www.wordfence.com/threat-intel/vulnerabilities/id/97fbbf5b-d3c7-47ce-b251-ce1fe38af152?source=cve
Get alerted when CVE-2024-5868 or the next vulnerability affects your stack