What’s Vulnerable › Vulnerabilities
CVE-2024-5882: Ultimate Classified Listings < 1.3 - Unauthenticated LFI
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-07-29 · updated 2026-06-17
- Weakness: CWE-22
Description
The Ultimate Classified Listings WordPress plugin before 1.3 does not validate the `ucl_page` and `layout` parameters allowing unauthenticated users to access PHP files on the server from the listings page
Affected products
- webcodingplace Ultimate Classified Listings: before 1.3 — fixed in 1.3
How to fix
Upgrade to a fixed version: webcodingplace Ultimate Classified Listings 1.3. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/5e8d7808-8f3e-4fc9-a1e7-e108da031ca7/
- https://wpscan.com/vulnerability/5e8d7808-8f3e-4fc9-a1e7-e108da031ca7/
Get alerted when CVE-2024-5882 or the next vulnerability affects your stack