What’s Vulnerable › Vulnerabilities
CVE-2024-5902: UserFeedback Lite <= 1.0.15 - Unauthenticated Stored Cross-Site Scripting via Name Parameter
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-07-12 · updated 2026-06-17
- Weakness: CWE-79
Description
The User Feedback – Create Interactive Feedback Form, User Surveys, and Polls in Seconds plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the name parameter in all versions up to, and including, 1.0.15 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in feedback form responses that will execute whenever a high-privileged user tries to view them.
Affected products
- smub UserFeedback – Create Interactive Feedback Form, User Surveys, and Polls in Seconds: before 1.0.16 — fixed in 1.0.16
How to fix
Upgrade to a fixed version: smub UserFeedback – Create Interactive Feedback Form, User Surveys, and Polls in Seconds 1.0.16. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/userfeedback-lite/tags/1.0.15/includes/frontend/class-userfeedback-frontend.php#L257
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bce9ba42-f574-47c1-9ea5-1e56f9da8e71?source=cve
- https://plugins.trac.wordpress.org/browser/userfeedback-lite/tags/1.0.15/includes/frontend/class-userfeedback-frontend.php#L257
- https://www.wordfence.com/threat-intel/vulnerabilities/id/bce9ba42-f574-47c1-9ea5-1e56f9da8e71?source=cve
Get alerted when CVE-2024-5902 or the next vulnerability affects your stack